漏洞概要

缺陷编号:
CNNVD-201802-974

漏洞标题:
GNU Binutils Binary File Descriptor库安全漏洞

提交时间:
2018-03-01

危害等级:

相关厂商:

漏洞分类:
漏洞公布

关注度:
共 9 人关注

漏洞详情

漏洞信息详情

GNU Binutils Binary File Descriptor库安全漏洞

漏洞简介

GNU Binutils(又名GNU Binary Utilities或binutils)是GNU计划开发的一组编程语言工具程序,它主要用于处理多种格式的目标文件,并提供有连接器、汇编器和其他用于目标文件和档案的工具。Binary File Descriptor(BFD)library(又名libbfd)是其中的一个以各种格式便携式操作对象文件的库。

GNU Binutils 2.30版本中的BFD库的dwarf1.c文件的‘parse_die’函数存在安全漏洞。远程攻击者可借助损坏的dwarf1调试信息利用该漏洞造成拒绝服务(整数溢出和应用程序崩溃)。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://sourceware.org/bugzilla/show_bug.cgi?id=22894

参考网址

来源:MISC

链接:https://sourceware.org/bugzilla/show_bug.cgi?id=22894

受影响实体

    暂无

补丁

    暂无

发表评论

电子邮件地址不会被公开。 必填项已用*标注